Cannot submit support tickets in Galaxy
Incident Report for Meteor Cloud
Resolved
Support ticket filing capability through the Galaxy management interface is back online.
Posted Oct 13, 2016 - 17:37 EDT
Identified
Due to a Zendesk system outage, you cannot submit support tickets through Galaxy.

Please submit support issues by emailing support@meteor.com
Posted Oct 13, 2016 - 14:44 EDT