Meteor APM metrics delay
Incident Report for Meteor Cloud
Resolved
We have identified that the secondary node of our second shard of APM was not responding to reads. This caused some apps that are allocated in this database to have a halt in the metrics shown.

We are working with the database provider to understand what could be the cause, but for now, we have changed for reading the primary node and the metrics will be processed from now on.

We are sorry for the inconvenience.
Posted Jan 19, 2021 - 21:10 EST
Identified
We have identified an issue with our DB monitoring, and one of our shards had a high CPU usage causing some metrics to be delayed on the second shard. We are deploying a fix right now but might take some time to catch up.
Posted Jan 19, 2021 - 11:34 EST
This incident affected: Meteor APM.