Reset password emails failing on Meteor Developer Accounts
Incident Report for Galaxy
Resolved
We've fixed the email outage.
Posted 8 months ago. Jun 23, 2017 - 14:39 PDT
Investigating
The Meteor Developer Accounts server is failing to send emails such as "reset password" emails.
Posted 8 months ago. Jun 23, 2017 - 14:37 PDT