Deploy server partial outage
Incident Report for Galaxy
Resolved
This incident has been resolved.
Posted 2 days ago. Aug 15, 2019 - 09:42 PDT
Monitoring
We believe we may have addressed the partial outage of the deploy server. Please contact support if you see more issues with deploying at this point.
Posted 2 days ago. Aug 14, 2019 - 20:01 PDT
Update
A percentage of all interactions with the deploy server continue to fail. We will continue to investigate.

When deploying, the meteor command-line client runs one deploy RPC followed by many status RPCs to learn if the app has successfully deployed. In many cases it appears to be the status RPC that is failing rather than the deploy RPC. As a workaround, you can run your deploy with `meteor deploy --no-wait`, which will finish with success as soon as your application's code has been successfully uploaded to Galaxy rather than waiting for it to be reported as a success. As far as we tell, all the machinery that happens after your code is successfully uploaded (building it into an image, running it on servers) is unaffected by the outage; it's just the initial upload, the dashboard, and the checks done by the deploy command after the initial upload.
Posted 3 days ago. Aug 14, 2019 - 15:43 PDT
Investigating
Deploys to Galaxy are sometimes failing due to issues with the deploy server. In some cases these issues are preventing deploys from going through; in other cases, the deploys work properly but the meteor command-line tool is unable to query the server for deploy status and prints unhelpful messages like "Internal Error". We are working to restore full operability for the deploy server.
Posted 3 days ago. Aug 14, 2019 - 01:10 PDT
This incident affected: Galaxy US infrastructure.