Some users are experiencing issues logging in to Galaxy
Incident Report for Galaxy
Resolved
While this specific issue is resolved, we are still investigating possible causes. We encourage users to contact support if they are having problems accessing Galaxy.
Posted over 1 year ago. Jul 03, 2017 - 17:18 PDT
Investigating
We are currently investigating reports from a few users that they are unable to log in to the Galaxy web interface in the us-east-1 region. In some cases clearing cookies & local storage resolves the issue.
Posted over 1 year ago. Jun 26, 2017 - 20:49 PDT