Let's Encrypt - Certificate issuance is temporarily unavailable
Incident Report for Meteor Cloud
Resolved
Certificate issuance is now restored.
Posted Oct 11, 2021 - 20:58 EDT
Identified
The issue has been identified and a fix is being implemented by Let's Encrypt.
Posted Oct 11, 2021 - 20:37 EDT
Investigating
We use Let's Encrypt to generate SSL Certificates and they are currently unavailable.

You can read more here https://letsencrypt.status.io/pages/incident/55957a99e800baa4470002da/6164b5af714e1f053880ba0c

As we depend on then to generate Certificates we can't generate certificates at the moment.
Posted Oct 11, 2021 - 20:37 EDT
This incident affected: Galaxy US infrastructure, Galaxy EU Infrastructure, and Galaxy AP Infrastructure.