We are continuing to monitor for any further issues.
Posted Nov 04, 2024 - 07:28 EST
Update
We are still collecting some more information and monitoring it.
Posted Nov 01, 2024 - 12:02 EDT
Update
We are continuing to monitor for any further issues.
Posted Oct 30, 2024 - 10:42 EDT
Update
We are continuing to monitor for any further issues.
Posted Oct 25, 2024 - 15:52 EDT
Update
We are continuing to monitor for any further issues.
Posted Oct 24, 2024 - 10:36 EDT
Update
We are continuing to monitor for any further issues.
Posted Oct 24, 2024 - 08:51 EDT
Monitoring
Dear Customers,
We recently experienced a major DDoS attack that hit our systems with over 53 million malicious requests within a short period, causing a brief outage in our Galaxy Europe region today, from 12 AM to 12:30 am GMT. Our team has identified the issue and are actively working on it. We stabilized for now.
We apologize for any inconvenience this may have caused and appreciate your understanding.