Minor Instabilities on US region

Incident Report for Meteor Cloud

Resolved

This incident has been resolved.
Posted Nov 04, 2024 - 07:28 EST

Update

We are continuing to monitor for any further issues.
Posted Nov 02, 2024 - 16:02 EDT

Monitoring

We want to inform you that we are currently experiencing minor instabilities in our US region infrastructure. We have already identified and applied changes to overcome that.
Posted Nov 01, 2024 - 19:40 EDT
This incident affected: Galaxy US infrastructure.