Issue on Galaxy Mailing System
Incident Report for Meteor Cloud
Resolved
This incident has been resolved.
Posted Feb 06, 2024 - 18:10 EST
Investigating
We are currently investigating issues with our mailing system. Clients may experience unusual behavior when sending emails. This only affects the mailing system; all other features are working correctly.
Posted Feb 02, 2024 - 13:15 EST
This incident affected: Galaxy US infrastructure, Galaxy EU Infrastructure, and Galaxy AP Infrastructure.