Old notifications being sent today
Incident Report for Meteor Cloud
Postmortem

The issue was identified and fixed.

It was stuck due to a wrong notification breaking a loop and now we don't have this problem anymore as we removed the wrong notification and fixed the code that caused it in the first place.

This loop was causing performance issues on Galaxy Dashboard UI (us-east-1 only), you should notice Galaxy Dashboard UI a lot faster now.

Sorry for the trouble.

Posted Sep 17, 2020 - 19:38 EDT

Resolved
This incident has been resolved.
Posted Sep 17, 2020 - 19:37 EDT
Identified
The issue was identified and fixed.

It was stuck due to a wrong notification breaking a loop and now we don't have this problem anymore as we removed the wrong notification and fixed the code that caused it in the first place.

This loop was causing performance issues on Galaxy Dashboard UI (us-east-1 only), you should notice Galaxy Dashboard UI a lot faster now.

Sorry for the trouble.
Posted Sep 17, 2020 - 19:31 EDT
Investigating
We had an issue in our notification system that it is sending old notifications, we are already working in the fix.

If you have received many emails saying your app is unavailable or something similar they are old notifications. Don't worry and sorry for the trouble.
Posted Sep 17, 2020 - 19:12 EDT
This incident affected: Galaxy management interface.