Galaxy is experiencing instability.

Incident Report for Meteor Cloud

Resolved

This incident is now resolved.

We have successfully restored all the affected services and are monitoring the results.
Posted Dec 15, 2023 - 17:40 EST

Investigating

Galaxy apps and our website are currently unstable and experiencing issues.
Posted Dec 15, 2023 - 17:24 EST
This incident affected: Galaxy US infrastructure, Galaxy management interface, Galaxy EU Infrastructure, Galaxy AP Infrastructure, and Meteor Cloud.