letsencrypt.org outage, automatic certificates are not available
Incident Report for Meteor Cloud
Resolved
LetsEncrypt has reported that their issue is resolved, and our monitoring agrees.
Posted May 19, 2017 - 19:18 EDT
Monitoring
Due to an ongoing incident with letsencrypt.org, it is currently impossible to get automatic certificates through the app settings page. Existing certificates are not affected as renewed significantly before expiration. https://letsencrypt.status.io/ for detailed updates.
Posted May 19, 2017 - 06:25 EDT