let's encrypt service disruption
Incident Report for Galaxy
Resolved
We have resolved the issue with certificate generation. New Let's Encrypt certificates are being generated again.
Posted about 1 year ago. Jun 29, 2017 - 19:36 PDT
Identified
We have identified the issue with certificate generation and are working to resolve the issue now.
Posted about 1 year ago. Jun 29, 2017 - 18:13 PDT
Investigating
We are investigating issues with Let's Encrypt certificate issuance.

Users attempting to enable automatic SSL may experience delays in certificate generation.

Existing apps already using SSL are not affected.
Posted about 1 year ago. Jun 29, 2017 - 16:33 PDT