PDF invoices are unavailable
Incident Report for Galaxy
Resolved
We have restored PDF invoice download to the Galaxy management interface.
Posted over 1 year ago. Jul 29, 2017 - 01:28 PDT
Identified
PDF invoices are currently unavailable on the Galaxy management interface. We are working to fix this issue.
Posted over 1 year ago. Jul 29, 2017 - 00:25 PDT