Deploys of apps running versions of Meteor older than 1.4 are failing
Incident Report for Meteor Cloud
Resolved
All clusters are now updated to a base image which pins the newest version of npm which is not incompatible with v0.10. Note that it will still print a message in the build process saying that v0.10 is not supported, but it should avoid the bug that some users encountered this morning.

Deploys with versions of Meteor prior to 1.4 should now succeed. We encourage our users to upgrade to Meteor 1.4 and enjoy the experience of its updated Node.js platform.
Posted May 16, 2017 - 14:28 EDT
Identified
We have verified that pinning npm@v4.5.0 will resolve this issue. We will deploy an updated base image.
Posted May 16, 2017 - 13:41 EDT
Investigating
The default Galaxy build process runs using the newest version of npm, and a newly released npm version does not support the old versions of Node used by versions of Meteor older than 1.4.

This only affects new deploys; containers for successfully built versions can still start.

We are working to fix the build process. Affected apps can also upgrade their version of Meteor.
Posted May 16, 2017 - 13:24 EDT