Issues logging in to the Galaxy dashboard
Incident Report for Galaxy
Resolved
We have fixed the issue with our accounts server. Login and deployment should be functional.
Posted 6 months ago. Feb 14, 2019 - 11:10 PST
Investigating
We are looking into issues with our accounts server affecting login and deployment.

Apps currently running should be unaffected.
Posted 6 months ago. Feb 14, 2019 - 11:01 PST
This incident affected: Galaxy management interface and Meteor Developer Accounts server.